1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Welcome to VapeHaven!
    If you like it here you can always register and become a part of the community :-)
  3. Good day Guest. The current Admin/Mod team are not getting to participate actively on the forum as we would want to, and the community deserves more than that. If you are an energetic, passionate vaper who can drive quality content(!!!), keep some order (not that we enforce any rules really :)) and would like to become part of the VH Team, please send me a PM. Papa OUT!

Cuboid and Tornado nano atomizer short?

Discussion in 'Problems + Troubleshooting' started by Wyvern, Sep 15, 2016.

  1. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    I have been getting on the tornado nano atomizer short when I use it on the cuboid, its fine on the evic mini, but on the cuboid I constantly get atomizer short. My normal tornado and Mizer supreme has no issues at all like that.
     
  2. Moonunit

    Moonunit Staff Member Moderator

    Joined:
    Aug 21, 2015
    Messages:
    262
    Location:
    Cape Town
    Ratings:
    +65 / 6 / -0
    It is the spring loaded 510 on the cuboid, mine has a similar issue. Tanks with a fixed pin seem to give that issue sometimes. Clean the thread on the cuboid and make sure the insulation around the pin is tucked in nicely. You can also try pulling the positive pin up a little with ceramic tweezers.

    I think the problem is the spring starts to wear out on the positive pin over time.


    Sent from my iPhone using Tapatalk
     
  3. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    I have a feeling its the spring, wonder if I can replace it. Cos its the only tank that does it
     
  4. Moonunit

    Moonunit Staff Member Moderator

    Joined:
    Aug 21, 2015
    Messages:
    262
    Location:
    Cape Town
    Ratings:
    +65 / 6 / -0
    You will probably find the tank's 510 is quite short when you compare to your Aromamiser.


    Sent from my iPhone using Tapatalk
     
  5. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    Yep, if I pull it out a bit then it connects, but it works for 5mins then stops again, need to figure out how to make it permanent
     
  6. Moonunit

    Moonunit Staff Member Moderator

    Joined:
    Aug 21, 2015
    Messages:
    262
    Location:
    Cape Town
    Ratings:
    +65 / 6 / -0
    Check out DJls Vapes, he strips the Cuboid in his video, might help?




    Sent from my iPhone using Tapatalk
     
  7. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    I dont have the right tools to open it, might take the mod to Mark at Juicy to see if he can help
     
  8. Moonunit

    Moonunit Staff Member Moderator

    Joined:
    Aug 21, 2015
    Messages:
    262
    Location:
    Cape Town
    Ratings:
    +65 / 6 / -0
    @Wyvern I'm sure they can help, wouldn't be surprised if they haven't done a fix before.


    Sent from my iPhone using Tapatalk
     
  9. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    Yea he is good, managed to get the mini volt sorta working again after my dad threw it :p
     
  10. LeonRSA

    LeonRSA Active Member

    Joined:
    Dec 19, 2015
    Messages:
    753
    Gender:
    Male
    Location:
    KZN
    Ratings:
    +386 / 58 / -0
    Hi @Wyvern , did you get this problem sorted?
     
  11. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    Hey there nope, the cuboid died a lovely death as well as my evic mini ironically a week later
     
  12. LeonRSA

    LeonRSA Active Member

    Joined:
    Dec 19, 2015
    Messages:
    753
    Gender:
    Male
    Location:
    KZN
    Ratings:
    +386 / 58 / -0
    Sorry to hear that.
    I managed to get mine working after months of trying different suggestions / fixes I found on the forums, without any luck. In the end I worked it out by myself...:rolleyes:
     
  13. Wyvern

    Wyvern Active Member

    Joined:
    Oct 27, 2015
    Messages:
    677
    Gender:
    Female
    Location:
    Cape Town
    Ratings:
    +396 / 82 / -0
    Lucky you! I ended up donating mine as spare parts
     

Share This Page